As of TestRail 5.6, PHP 5.6 is no longer supported. PHP 5.6 active support has officially ended on Jan, 19 2017 with security support ending on Dec, 31 2018. So please note, even if TestRail 5.6 works in your PHP 5.6 environment, we don’t support the configuration any longer and some features might not work well.

Upgrade in Linux

TestRail 5.6 now offers support for PHP versions 7.1 & 7.2. You can upgrade your PHP version via your command line. E.g. in Ubuntu:

To make sure you have the required additional repository enabled:

sudo add-apt-repository ppa:ondrej/php
Sudo apt-get update
Sudo apt-get install php7.2

Once it’s installed, ensure you also install all of the PHP extensions required to run TestRail:

Sudo apt-get install php7.2-mbstring php7.2-mysql php7.2-curl php7.2-json php7.2-zip php7.2-xml

Next, it’s time to update the IonCube Loader. You will have this referenced already in your current TestRail installation and you’ll just need to update your php.ini file(s) to reflect the PHP 7 version. For example, you would update your php.ini file to show the following when upgrading to PHP 7.2:

zend_extension = /opt/ioncube/ioncube_loader_lin_7.2.so

You will need to disable PHP 5.6 modules and enable PHP 7 modules:

sudo a2dismod php5.6
sudo a2enmod php7.2

Note: Please restart your web server services for the changes above to take effect.

Now you’re ready to upgrade to TestRail 5.6. We highly recommend creating a backup before upgrading!

To upgrade TestRail, simply download the latest version from your company's customer portal account.

Upgrading TestRail is very easy and you basically just need to copy the new files over your existing installation and click through the database upgrade wizard. You can learn more about the upgrade process here.

Upgrade in Windows

Install php version 7.1 or 7.2 via the Web Platform Installer along with the appropriate drivers:

This will include all of the PHP extensions needed to run TestRail except the IonCube loader. You’ll need to download the IonCube loader separately with the following steps:

  • Download the IonCube loader wizard (which is a requirement to run TestRail).
  • Extract all of the files and copy the ioncube folder to
    inetpub/wwwroot/
  • Navigate to
    localhost/ioncube/loader-wizard.php
  • This will prompt the loader-wizard to identify the exact IonCube loader needed for your system and PHP version. Simply follow the instructions from the loader-wizard page to install the correct loaders and then add the necessary reference to the loader in your php.ini file. The reference should look similar to this and should be added before any other zend_extension lines:

Next be sure to restart IIS in the command prompt via:

iisreset

Once this is done run the php -v command in the command prompt to ensure the correct PHP version is being used and the IonCube loader is installed correctly.

Please note: In order for IIS to be able to load the extension, it may need the ionCube extension file permission changes. To do this, right-click the file in Explorer > Properties, select the Security tab and add the Users group.

You should receive a successful message like the one below if everything was done correctly:

We would highly recommend creating a backup of your database before upgrading to the new version of TestRail. You can do this in SQL Server Management Studio by expanding databases, right clicking on your testrail database, click tasks, then select backup.

To upgrade TestRail, simply download the latest version from your company's customer portal account here.

Extract and copy your files over to inetpub/wwwroot replacing your current files. Once this is done navigate to localhost/testrail and follow the upgrade steps. You should then receive the TestRail 5.6 banner as so:

That’s it. If everything worked, you’re now able to enjoy TestRail 5.6 on PHP 7.0, 7.1 & 7.2!